Comskip Support Forum

Comskip is a free commercial detector, browse the forum for more information
It is currently Wed Nov 22, 2017 7:31 pm

All times are UTC [ DST ]




Post new topic Reply to topic  [ 7 posts ] 
Author Message
 Post subject: Speed Doubt
PostPosted: Fri Oct 06, 2017 8:38 am 
Offline

Joined: Fri Oct 06, 2017 8:36 am
Posts: 4
Hi,

By the first time, i would want to appreciate the work of the project. I have already use it and it's fantastic. Thanks you very much.

My goal is detect commercial breaks in h264 videos and I have a doubt related with the speed. In my tests, I have seen that the speed in my Linux computer is ~80fps and I want to know if it's the maximum speed for this kind of video codec (h.264).

With other videos (MPEG2), the normal speed is approximately 600-800fps.

If it's the normal speed, what do you recommend me for decrease the analysis time? Maybe decode the video to MPEG2? Hardware assist?


Thanks you very much and I repeat, I appreciate your work very much.


Top
 Profile  
Reply with quote  
 Post subject: Re: Speed Doubt
PostPosted: Fri Oct 06, 2017 12:26 pm 
Offline
Site Admin

Joined: Sun Aug 21, 2005 3:49 pm
Posts: 3098
Did you try the
lowres=10
setting?


Top
 Profile  
Reply with quote  
 Post subject: Re: Speed Doubt
PostPosted: Fri Oct 06, 2017 12:26 pm 
Offline
Site Admin

Joined: Sun Aug 21, 2005 3:49 pm
Posts: 3098
Sometimes using the hw acceleration could also help, but not always


Top
 Profile  
Reply with quote  
 Post subject: Re: Speed Doubt
PostPosted: Wed Oct 11, 2017 7:57 am 
Offline

Joined: Fri Oct 06, 2017 8:36 am
Posts: 4
erik wrote:
Did you try the
lowres=10
setting?


I don´t see this setting. Is in the INI file or in the command line parameters?

Thank you.


Top
 Profile  
Reply with quote  
 Post subject: Re: Speed Doubt
PostPosted: Wed Oct 11, 2017 8:00 am 
Offline

Joined: Fri Oct 06, 2017 8:36 am
Posts: 4
erik wrote:
Sometimes using the hw acceleration could also help, but not always


In this case, in my computer, it doesn´t help, is the same speed.

If I try in other PC, what is more useful: more CPU or GPU?


Thank you so much for your help.


Top
 Profile  
Reply with quote  
 Post subject: Re: Speed Doubt
PostPosted: Wed Oct 11, 2017 8:01 am 
Offline
Site Admin

Joined: Sun Aug 21, 2005 3:49 pm
Posts: 3098
add the line
lowres=10
to your comskip.ini file
for h.264 there are people reporting that gpu acceleration can help but as I do not have a fast gpu I did not see myself
For 1920x1080 h.264 I get about 200fps on a i7-2600 at 3.4GHz
What is the cpu you are using?


Top
 Profile  
Reply with quote  
 Post subject: Re: Speed Doubt
PostPosted: Wed Oct 11, 2017 1:32 pm 
Offline

Joined: Fri Oct 06, 2017 8:36 am
Posts: 4
erik wrote:
add the line
lowres=10
to your comskip.ini file
for h.264 there are people reporting that gpu acceleration can help but as I do not have a fast gpu I did not see myself
For 1920x1080 h.264 I get about 200fps on a i7-2600 at 3.4GHz
What is the cpu you are using?


I test with the line lowres=10 and it´s the same speed.

My cpu is Intel(R) Core(TM)2 Duo CPU E7400 @ 2.80GHz.

Ok, with your value I know that is a normal speed. I will try with other PC with more CPU and GPU.


Thanks you so much.


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 7 posts ] 

All times are UTC [ DST ]


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group