eyetv or HD detection problems

To discuss the tuning of comskip and for posting your ini files
erik
Site Admin
Posts: 3361
Joined: Sun Aug 21, 2005 3:49 pm

eyetv or HD detection problems

Post by erik »

Some general advice to improve the detection performance h.264 content

Set
min_show_segment_length=250

and if you see detection gets worse later in the recording you can set
volume_slip=300

This has helped many people.
dr01dy
Posts: 13
Joined: Thu Jan 12, 2012 5:46 pm

Re: eyetv or HD detection problems

Post by dr01dy »

I noticed on the new donation version past v44 that Happauge HDPVR+EyeTV stopped working.

I am currently setting these attributes and will respond with a working .ini for everyone.

Jeff
erik
Site Admin
Posts: 3361
Joined: Sun Aug 21, 2005 3:49 pm

Re: eyetv or HD detection problems

Post by erik »

Glad to hear.
I understood it is a tuning problem?
If so I would like to receive a "How to ask for help" set of files so I can include the generated .csv and the .ref in my global optimisation test set.
dr01dy
Posts: 13
Joined: Thu Jan 12, 2012 5:46 pm

Re: eyetv or HD detection problems

Post by dr01dy »

I got everything working except for it won't mark the commercials itself I need to run the script manually after the recording in eyetv with from terminal

./Library/Application Support/ETVComskip/MarkCommercials.app/Contents/MacOS/MarkCommercials
flyingout
Posts: 9
Joined: Tue Jan 17, 2012 5:37 am

Re: eyetv or HD detection problems

Post by flyingout »

dr01dy wrote:I got everything working except for it won't mark the commercials itself I need to run the script manually after the recording in eyetv with from terminal

./Library/Application Support/ETVComskip/MarkCommercials.app/Contents/MacOS/MarkCommercials
If you're using the donators version, it doesn't yet support live detection. It gets started but stops soon thereafter.

Mine are heavily customized but if memory serves the latest ETVComskip start and end recording scripts do call MarkCommercials from the start script, i.e., live detection. What I did was comment out the call in the start script and added it to the stop script.

If this does apply to you and you need more details, let me know.

Cheers
dr01dy
Posts: 13
Joined: Thu Jan 12, 2012 5:46 pm

Re: eyetv or HD detection problems

Post by dr01dy »

Chris,

Yes you are dead on, I have the donator version with eyetv-comskip installed with eyetv and trying to get H264. Maybe we can share .ini files or something.

Thanks for the reply!
erik
Site Admin
Posts: 3361
Joined: Sun Aug 21, 2005 3:49 pm

Re: eyetv or HD detection problems

Post by erik »

Can one you you post a short dedicated topic on how to adopt eyetv to get the current comskip donator version working?
Preferrably with a nice catching topic line so google will find it.
dr01dy
Posts: 13
Joined: Thu Jan 12, 2012 5:46 pm

Re: eyetv or HD detection problems

Post by dr01dy »

erik,

No problem I will work on that in the morning over a cup of coffee ;)
flyingout
Posts: 9
Joined: Tue Jan 17, 2012 5:37 am

Re: eyetv or HD detection problems

Post by flyingout »

erik wrote:Can one you you post a short dedicated topic on how to adopt eyetv to get the current comskip donator version working?
Preferrably with a nice catching topic line so google will find it.
I could certainly do that. I just need to dig up the original scripts so that I'm writing about the default configuration. Unless live recording support is coming back soon, you may want to note that it doesn't work a bit more prominently near the top of the readme.

I assume the Support forum would be the best place to post the instructions.

Cheers
flyingout
Posts: 9
Joined: Tue Jan 17, 2012 5:37 am

Re: eyetv or HD detection problems

Post by flyingout »

dr01dy wrote:Chris,

Yes you are dead on, I have the donator version with eyetv-comskip installed with eyetv and trying to get H264. Maybe we can share .ini files or something.

Thanks for the reply!
Who's Chris? :wink: I assume you were responding to me though.

H264? I'm running comskip against the default EyeTV recordings, which are just mpeg in my case. Are you converting first? Or are recordings H264 with some devices?

Anyway, I've done very little customizing of the .ini file. Just:

live_tv=1 ; doesn't appear to cause any harm when run after recording
live_tv_retries=16 ; this is what I used previously. I'll have to see what's best here once live_tv is back.
thread_count=8 ; Nice! (I didn't know it would work under Wine.) Except for 1080i recordings, this might even obviate the need to do live_tv processing at all. It speeds things up quite a bit.

Cheers
dr01dy
Posts: 13
Joined: Thu Jan 12, 2012 5:46 pm

Re: eyetv or HD detection problems

Post by dr01dy »

I am not sure where I got chris from, anyways livetv detection was working on donator version 42 and it must have stopped working at some point with the new ever versions.
erik
Site Admin
Posts: 3361
Joined: Sun Aug 21, 2005 3:49 pm

Re: eyetv or HD detection problems

Post by erik »

Live TV (that is: detection DURING recording) works on the 0.80.x version.
It never worked on the 0.81.x versions as I till today have not been able to implement it in a reliable way.
If you do not need to process .wtv you are better of with the latest 0.80.x build

The live_tv setting in comskip is only determining if comskip will output commercial information while it processes the file, not WHEN comskip is started.

So with the 0.81.x build live_tv_retries and the standoff setting are useless till further notice

I know its confusing and I wish I was able to implement live tv processing but I had other priorities....
dr01dy
Posts: 13
Joined: Thu Jan 12, 2012 5:46 pm

Re: eyetv or HD detection problems

Post by dr01dy »

I just used Thread=8 on my i7 2.66 6mins for 60min show. Thats blazing fast compared to before.
erik
Site Admin
Posts: 3361
Joined: Sun Aug 21, 2005 3:49 pm

Re: eyetv or HD detection problems

Post by erik »

Happy to hear.
Spread the word.
dr01dy
Posts: 13
Joined: Thu Jan 12, 2012 5:46 pm

Re: eyetv or HD detection problems

Post by dr01dy »

erik,

Thanks for the information. I am going to rollback now and give it a shot. once I see it working I am going to start a new post as we talked about above for new users.

Thanks again,

Jeff
Post Reply