Some queries about tuning.....

To discuss the tuning of comskip and for posting your ini files
Post Reply
Taipan
Posts: 26
Joined: Sun Jun 18, 2006 12:39 am
Location: Melbourne, Australia

Some queries about tuning.....

Post by Taipan »

Hi Erik,

I am really impressed by Comskip and Comclean - well done... :)

I have been trying to "fine tune" my comskip.ini and there are a couple of things that I don't understand, that don't appear to be covered in the documentation. Could you please explain what the lines:-

validate_silence=1 ; Default, set to 0 to force using this clue if selected above.
validate_uniform=1 ; Default, set to 0 to force using this clue (like pure white frames) if blackframe is selected above.
validate_scenechange=1 ; Default, set to 0 to force using this clue if selected above.


mean? Under what circumstances would I set these options to "0"?

I have the lines

max_volume=5 ; any frame with sound volume larger than this will not be regarded as black frame
min_silence=5 ; Any deep silence longer than this amount of frames is a possible cutpoint


but I notice that comskip still counts frames with a volume greater than 5 as black frames, but these black frames are part of the program and not part of a commercial?

You might wonder why I have set the sound level is so low - I am analysing a DVB-T broadcast and the volume typically drops to zero during black frames before and after commercials, but doesn't go below 5 during scene fade within a program.

Cheers,

Taipan
erik
Site Admin
Posts: 3370
Joined: Sun Aug 21, 2005 3:49 pm

Post by erik »

Very interresting!

Could you mail me the .csv file of such a recording and a .txt file edited such that it contains the right information? Rename the .txt to .ref so comskip knows to use it as reference.
Also include the ini file you use
This will make it much easier for me to answer your questions and it will extend my collection of test files. :)

The validate_... are used as follows.
WHen you enable all detection methods some of them may be usefull for a certain recording, others not.
E.g. certain chines recordings no not have black frames around commercials, they only have black frames inside show. This implies that the blackframe method can not be used. By enabling the validate_... the method will be validated and if it seems unreliable it will be disabled to prevent wrong clues.
So if you know for sure a certain method MUST be used and the validation algorithm concludes wronly you can disable the validation.

My goal is one ini file for worldwide use.

The volume and silence question can only be answered when inspecting the csv file.
Taipan
Posts: 26
Joined: Sun Jun 18, 2006 12:39 am
Location: Melbourne, Australia

Post by Taipan »

I have just emailed the requested files to you - I hope you can make sense of my attempts at "tuning" - I have tried so many different combinations now, that I have got myself totally confused!
erik
Site Admin
Posts: 3370
Joined: Sun Aug 21, 2005 3:49 pm

Post by erik »

Here is my feedback

Use the following changes

min_show_segment_length=200
If you set this too low (such as 125) then a commercial of 125 seconds will no longer be recognized as commercial. This change is not realy needed when you do below change.

max_volume=100
min_silence=20
When you set max_volume too low Comskip can not detect deep silence required for silence cuts. Deep silence means volume is for min_silence seconds below max_volume/5.
If you set max_volume too high or min_silence too short you get false silence cuts....

Try setting
logo_threshold=0.55
for a more reliable logo detection. It still will not be very good.

Try recording with prepadding, start at least 1 minute before the actual show starts. This will help Comskip to discard the wrongly detected commercial at the start.

Are these initial 10 + 16 seconds realy part of the show or is this some kind of intro? Both short blocks qualify for commercial for multiple reasons so it will be difficult to change this unless there is something before it.
Taipan
Posts: 26
Joined: Sun Jun 18, 2006 12:39 am
Location: Melbourne, Australia

Post by Taipan »

Thanks for those suggestions - I will give them a try tonight... :)

I have some queries on the format of the comskip.ini file, as I understand that it is quite "picky" (to use your words):-

Is it permissible to have blank lines (only a CR) or lines with only a semicolon in them and some text (explanation or heading text)? I ask this, because it makes it easier for me to read and understand if I can separate the groups of settings with a blank line, or some text to explain what the next group of settings belong to.

Does the order of the settings matter? It appears that as long as a setting appears somewhere in the file, it is OK? I understand that if a setting appears more than once, only the first occurrence is accepted.

The setting "border" has a default value of 10 - is that in pixels or % of total screen height/width?

And what does the setting "ms_audio_delay=5" mean or do?

Cheers,

Taipan
erik
Site Admin
Posts: 3370
Joined: Sun Aug 21, 2005 3:49 pm

Post by erik »

Is it permissible to have blank lines (only a CR) or lines with only a semicolon in them and some text (explanation or heading text)?
YES

Does the order of the settings matter?
NO

I understand that if a setting appears more than once, only the first occurrence is accepted.
YES

The setting "border" has a default value of 10 - is that in pixels or % of total screen height/width?
I think it is pixels

And what does the setting "ms_audio_delay=5" mean or do?
Only used for dvr-ms, needed to ensure my demux keeps audio and video synced.
See the thread discussing dvr-ms
Post Reply