Page 1 of 1

subtitle PID in VPrj missing

Posted: Sun Aug 19, 2012 11:14 am
by Jagad

The latest version doesnt seem to find any subtitle PID. Always says 0 despite the teletext subs are there. Dont know how many versions back it stopped working.

Re: subtitle PID in VPrj missing

Posted: Sun Aug 19, 2012 1:17 pm
by erik
Since I changed demuxer to make .wtv working subtitle processing as stopped working.
Its a rather difficult piece of code
Do you only need the PID?

Re: subtitle PID in VPrj missing

Posted: Sun Aug 19, 2012 1:35 pm
by Jagad
Yes, only the PID for the subtitle is needed...otherwise Videoredo won't pick it up and subs will be excluded in edited recording.
Amused myself with some backtracing and discovered last time the Subtitle PID identifyer worked was on the Comskip81_031_donators. Build 032 and later didn't work. I suppose the demuxer thingie you're mention is the first on the list of changes for 032.
Changes on 0.81.032
- Improved/repaired reviewing video for dvr-ms and wtv files. Still not fully working for bad timeline video's
- Discovered a crash when thread_count>1 and the recording changes video size, This crash can NOT be solved at the moment. If you see comskip crashing set thread_count=1
- Solved crash when video size changes even when thread count was set to 1
- Solved wrong duration and wrong progress indicator for .wtv files
- Solved timing inconsistency between two_pass_logo=1 and two_pass_logo=0
- Solved occasional equal time shifting of all detected commercials
- Tested for robustness on more then 200 recordings samples from all over the world. Tested for accuracy on over 150 test recordings with manual detected commercials as reference.
BTW...i'm using comskip on .TS files only.