Extra Adverts found using Frame Array

Where all the bugs are reported and discussed
Post Reply
sheppy99
Posts: 88
Joined: Mon May 10, 2010 2:44 am

Extra Adverts found using Frame Array

Post by sheppy99 » Mon Feb 20, 2017 8:52 am

I've discovered that I get different results using the Frame Array file compared to scanning the file directly with no changes to comskip.ini What are the differences between the 2 modes apart from speed? As I'm using a pre found logo the full file scan uses 2 threads and the file is SD H264 / AAC-HE

erik
Site Admin
Posts: 3297
Joined: Sun Aug 21, 2005 3:49 pm

Re: Extra Adverts found using Frame Array

Post by erik » Mon Feb 20, 2017 9:00 am

There is a small difference that could trigger an on-the-edge condition.
can you make the recording available to me?

sheppy99
Posts: 88
Joined: Mon May 10, 2010 2:44 am

Re: Extra Adverts found using Frame Array

Post by sheppy99 » Mon Feb 20, 2017 9:04 am

Sure, I'll upload it in a couple of hours or so, assuming you will get chance to take a look later today? Otherwise is in about 12 hours ok?

erik
Site Admin
Posts: 3297
Joined: Sun Aug 21, 2005 3:49 pm

Re: Extra Adverts found using Frame Array

Post by erik » Mon Feb 20, 2017 9:22 am

Ping me when done

sheppy99
Posts: 88
Joined: Mon May 10, 2010 2:44 am

Re: Extra Adverts found using Frame Array

Post by sheppy99 » Mon Feb 20, 2017 11:19 am

erik wrote:Ping me when done
I just sent you a PM with the links in.
Its the break between frames 57264 & 59745 that is missing when scanned with the full file. The actual end of the commercial is at 59890 but as there isn't any black frames I haven't found a way to trigger it at that frame.

erik
Site Admin
Posts: 3297
Joined: Sun Aug 21, 2005 3:49 pm

Re: Extra Adverts found using Frame Array

Post by erik » Mon Feb 20, 2017 12:15 pm

Very helpfull recording. Need to find the root cause of the differences.

sheppy99
Posts: 88
Joined: Mon May 10, 2010 2:44 am

Re: Extra Adverts found using Frame Array

Post by sheppy99 » Mon Feb 20, 2017 7:48 pm

Glad you can reproduce it.
Whilst I was waiting for the upload to finish I tested dropping it down to 1 thread in case that was the cause but it made no difference.

erik
Site Admin
Posts: 3297
Joined: Sun Aug 21, 2005 3:49 pm

Re: Extra Adverts found using Frame Array

Post by erik » Tue Feb 21, 2017 4:28 pm

The decoder can not do real mutithreading on certain h.264 recordings.

erik
Site Admin
Posts: 3297
Joined: Sun Aug 21, 2005 3:49 pm

Re: Extra Adverts found using Frame Array

Post by erik » Wed Feb 22, 2017 5:47 pm

Differences between original processing and frame array based processing should be solved in next release.

sheppy99
Posts: 88
Joined: Mon May 10, 2010 2:44 am

Re: Extra Adverts found using Frame Array

Post by sheppy99 » Wed Feb 22, 2017 7:10 pm

Thanks!

erik
Site Admin
Posts: 3297
Joined: Sun Aug 21, 2005 3:49 pm

Re: Extra Adverts found using Frame Array

Post by erik » Thu Feb 23, 2017 8:44 am

Release done, can you test. I also added some error messages for wrong string parameters and cutscenefiles not found

sheppy99
Posts: 88
Joined: Mon May 10, 2010 2:44 am

Re: Extra Adverts found using Frame Array

Post by sheppy99 » Thu Feb 23, 2017 8:50 am

I'll give it a test tomorrow, I worked around it by adding 2 secs to shrink logo. Fortunately using a pre found logo gave me 2 threads for the full single pass scan, so I tested everything with a normal scan

sheppy99
Posts: 88
Joined: Mon May 10, 2010 2:44 am

Re: Extra Adverts found using Frame Array

Post by sheppy99 » Fri Feb 24, 2017 4:39 am

erik wrote:Release done, can you test. I also added some error messages for wrong string parameters and cutscenefiles not found
I've tested it on the file that I uploaded to you, and the next in the series and it has fixed the problem, the results of both a full scan and a csv scan differ by no more than 4 frames on some of the cuts, and none on others.
On my problem channel I still get differing results, this channel has very sloppy editing, with sometimes late logos, intermittent similar to normal logos during ads, no blackframes, no guaranteed silence, and similar uniformity between show and adverts. Fortunately we don't watch a lot of that, and the fast forward button works regardless of what they do! :lol:
If I find something that's has a reproducible significant difference between FrameArray and Full Snan, I'll upload a copy.
For now I'd call it a great improvement, and for most people its likely totally fixed.
Haven't tested the cutframes yet as other methods are working.
I'll deploy the latest release now to the recorder, thanks for the prompt fix

erik
Site Admin
Posts: 3297
Joined: Sun Aug 21, 2005 3:49 pm

Re: Extra Adverts found using Frame Array

Post by erik » Fri Feb 24, 2017 1:06 pm

There is indeed a small difference in logo processing I still need to solve.

Post Reply