Page 1 of 1

edl file updating problem

Posted: Thu Jan 26, 2006 10:02 am
by b00sfuk
Erik, don't know if this is a feature or a bug! If I update commercial positions via the preview screen (with txt file) and then use "w" it updates the txt file but also clears (=0bytes) rather than updates the edl file.

This is with 79.19, I tried an earlier version (79.11 as this fixed an earlier edl problem) and this does not touch the edl file after an update.

Can this be fixed as I like to manually review commercials before sending the file to be transcoded via mencoder.
thanks again for your support.

Posted: Thu Jan 26, 2006 7:19 pm
by erik
Directly after leaving comskip the length is 0, but after some seconds by magic it gets to the correct length, and you see the right content
I thinks thats because of the command window cleanup (un)logic.

Do you see the same?

Posted: Thu Jan 26, 2006 9:13 pm
by b00sfuk
Erik, no, the .edl file remains at 0 bytes. To doublecheck I put the comskip.exe & .ini from the 79.19 zip file in to a directory with the .mpg file. I then edit the .ini file to change output_edl=1 and drop the mpg file onto the comskip.exe. When finished I drop the .txt file onto the .exe, insert a commercial (with "i" - I've also tried without this step) and then write the file (with "w"). The .edl file immediately changes to 0 bytes and this does not change when windows are then closed. Also I can delete the .edl file first and it recreates it but at 0 bytes again.
I've also just tried 79.11 & 79.20 and on 2 different PCs with same result.

Posted: Thu Jan 26, 2006 9:52 pm
by erik
I fail to reproduce the problem for the moment.
Will take more time

Posted: Thu Jan 26, 2006 10:44 pm
by b00sfuk
Erik, thanks, sorted with latest version.

Posted: Fri Jan 27, 2006 11:11 am
by erik
Please upgrade to version 21 as version 20 may crash when no .edl output is selected.

Posted: Sat Jan 28, 2006 4:53 pm
by b00sfuk
Erik, one little problem left. The problem reappears if I create (or extend) a commercial to include the last frame. Not a major issue.

Posted: Sat Jan 28, 2006 10:46 pm
by erik
Will be solved in the next release

Posted: Fri Feb 03, 2006 4:51 pm
by b00sfuk
Erik, thanks, this works great now with 79.23. However I seem to have same problem at start of recording now. If I edit and add a commercial which starts at the beginning of the recording then "w" does not then include that block in the .edl OR the .txt file.

thanks again for all the support/updates you provide to comskip.

Posted: Fri Feb 03, 2006 5:35 pm
by erik
If you insert at the start of the recording the first commercial starts at 0
This is wrong.

Insert the commercial
Go to the start and hit 'B' to ensure the first frame number of the first commercial is not 0 but 1 or bigger.
The bug will be fixed in the next release.