Comskip Support Forum

Comskip is a free commercial detector, browse the forum for more information
It is currently Thu Oct 18, 2018 1:29 am

All times are UTC [ DST ]




Post new topic Reply to topic  [ 6 posts ] 
Author Message
PostPosted: Wed Dec 04, 2013 3:58 pm 
Offline

Joined: Tue Jan 31, 2012 12:13 am
Posts: 39
With play_nice_sleep set to 0, Comskip processes a file in about 10 minutes but uses 80% to 90% of CPU. Set to any non-zero integer, CPU use drops to about 5% and processing takes about an hour.
Something in between would be nice.
:wink:


Top
 Profile  
Reply with quote  
PostPosted: Wed Dec 04, 2013 6:50 pm 
Offline
Site Admin

Joined: Sun Aug 21, 2005 3:49 pm
Posts: 3211
On what CPU?


Top
 Profile  
Reply with quote  
PostPosted: Wed Dec 04, 2013 7:22 pm 
Offline

Joined: Tue Jan 31, 2012 12:13 am
Posts: 39
Celeron G530
http://www.costcentral.com/proddetail/Intel_Celeron_G530/BX80623G530/11436877/froogle/?gclid=COeu_-uXl7sCFcQDOgodqG0AWQ

Edit, after further testing:
=1 takes about 47 minutes
=-1 takes just about an hour
=5 takes just about an hour
=10 takes just about an hour
=100 would probably take most of the rest of my life.

Fractions of 1 just round down to 0, so my current options seem to be (as I originally postulated) 10 minutes at 85% or 50 minutes at 5%.
Something in between would be ideal.


Top
 Profile  
Reply with quote  
PostPosted: Sun Dec 15, 2013 3:34 pm 
Offline

Joined: Tue Jan 31, 2012 12:13 am
Posts: 39
Any hope of allowing a play_nice_sleep = 0.5 in the future?


Top
 Profile  
Reply with quote  
PostPosted: Sun Dec 22, 2013 11:17 am 
Offline
Site Admin

Joined: Sun Aug 21, 2005 3:49 pm
Posts: 3211
Nope,
Can't sleep shorter then a millisecond on windows for the moment.


Top
 Profile  
Reply with quote  
PostPosted: Sun Mar 02, 2014 2:24 pm 
Offline

Joined: Tue Jan 31, 2012 12:13 am
Posts: 39
Somehow, you fixed it anyway. :)
I missed a few, but just updated to 059. As you suggest, I ran it first with the default config file. It took about 8 minutes and used 90% to 95% of the CPU.
I then put in my play_nice code and it took about 45 minutes and used almost no CPU.
But setting play_nice_sleep = 0 now takes about 15 minutes with CPU usage between 45% and 50%.
PERFECT. :D
Many thanks again for your amazing efforts on this.
Michael


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 6 posts ] 

All times are UTC [ DST ]


Who is online

Users browsing this forum: No registered users and 11 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group