Comskip Support Forum
http://www.kaashoek.com/comskip/

Do not set THREAD_MODE_BACKGROUND_BEGIN if live_tv=1
http://www.kaashoek.com/comskip/viewtopic.php?f=4&t=730
Page 1 of 1

Author:  awhenry [ Sun Mar 29, 2009 7:32 pm ]
Post subject:  Do not set THREAD_MODE_BACKGROUND_BEGIN if live_tv=1

I debated whether this should be posted in "bugs", as I think the consequences of setting this are unintended. In any case, I recently updated to the latest donators version (80_021) from my previous 80_008. I immediately noticed that comskip was doing a very poor job at marking commercials, and seemed like it was crashing perhaps partway into some programming, at least that was what I thought. After further investigation, what is actually happening is that comskip is running very, very slowly, taking several hours to process each hour long program. During this time, comskip is idling at 0-2% CPU utilization. If I wait until nothing is recording, I disable my grid computing application (BOINC), and I make sure that nothing else is using the disks (virus scan, defrag, etc), then comskip will pick up the pace to normal speed. Sadly, this environment is incompatible with scanning live recordings, and basically results in having few or no commercials marked for any program watched the same day it was recorded.

For the time being I have downgraded to 80_016, the last version that does not set this priority level, and it is running at normal speed (i.e., keeping up with live recordings, even with all aforementioned applications running). Possibly, some users would want this priority setting made available, if comskip is too intrusive on I/O at the previous priority values (though I have never encountered that myself). However I do not believe that in any case it is compatible with live_tv mode, as it will always relinquish its disk access time to the busy recording application.

I should note that I am running Vista Business x64. I believe this priority value is only valid for Vista and later OSes; XP users would not be affected by this. It is my understanding that this priority setting affects I/O priority rather than CPU priority, and indeed in the task manager the priority of comskip is listed as "low" for all the versions I have tried. For the later sluggish versions, cranking up the CPU priority had no effect on the speed of its processing.

Thanks for your consideration.

--
Andrew

Author:  erik [ Sat Apr 04, 2009 7:50 pm ]
Post subject:  Re: Do not set THREAD_MODE_BACKGROUND_BEGIN if live_tv=1

Will be in build 23

Author:  awhenry [ Tue Apr 07, 2009 3:43 am ]
Post subject:  Re: Do not set THREAD_MODE_BACKGROUND_BEGIN if live_tv=1

Thanks!

The new build 23 appears to be keeping up just fine now marking live TV.

Page 1 of 1 All times are UTC [ DST ]
Powered by phpBB® Forum Software © phpBB Group
https://www.phpbb.com/