Comskip Support Forum

Comskip is a free commercial detector, browse the forum for more information
It is currently Wed Oct 01, 2014 5:15 pm

All times are UTC [ DST ]




Post new topic Reply to topic  [ 13 posts ] 
Author Message
PostPosted: Tue Feb 21, 2012 12:49 am 
Offline

Joined: Fri Jun 22, 2007 1:09 pm
Posts: 51
I am trying to trouble shoot a problem with Comskip crashing. I have enabled logging with Verbose = 10, but looking at the log doesn't reveal anything useful the log file is only 20 line or so long


Posting the log, I just noticed that my version is old. Will install the latest and monitor from there.
################################################################
Generated using Comskip 0.81.026
Time at start of run:
Sun Feb 19 22:09:04 2012
################################################################

Detection Methods to be used:
1) Black Frame
2) Logo - Give up after 2000 seconds
3) Scene Change
4) Resolution Change
5) Aspect Ratio


ComSkip throttles back from -0001 to -0001.
The time is now 2209 so it's full speed ahead!
Audio jumped by 0.000 at frame 0
Audio PTS jumped 9 frames at frame 0
Audio jumped by 0.000 at frame 0
Frame Rate set to 59.940 f/s
Frame: 1 Ratio: 1.77 MinY: 74 MaxY: 480 MinX: 1 MaxX: 720
Video jumped by 1.000 at frame 1, inter = 0, rep = 0, ticks = 2
Frame Rate set to 59.940 f/s
Audio jumped by 0.000 at frame 2
Video jumped by 0.500 at frame 2, inter = 0, rep = 0, ticks = 2
Frame Rate set to 59.940 f/s
Video jumped by 0.500 at frame 3, inter = 0, rep = 0, ticks = 2
Frame Rate set to 59.940 f/s
Audio jumped by 0.000 at frame 4
Video jumped by -92.000 at frame 4, inter = 0, rep = 0, ticks = 2
Video jumped by 0.000 at frame 5, inter = 0, rep = 0, ticks = 2
Audio jumped by 0.000 at frame 6
Audio PTS jumped -8 frames at frame 6
Audio jumped by 2.698 at frame 9
Video jumped by 161.199 at frame 11, inter = 0, rep = 0, ticks = 2
Video jumped by 0.000 at frame 63, inter = 0, rep = 0, ticks = 2
Video jumped by 0.000 at frame 65, inter = 0, rep = 0, ticks = 2
Video jumped by 0.000 at frame 67, inter = 0, rep = 0, ticks = 2
Video jumped by 0.000 at frame 69, inter = 0, rep = 0, ticks = 2
Audio jumped by 1.932 at frame 71
Video jumped by 0.000 at frame 71, inter = 0, rep = 0, ticks = 2


Top
 Profile  
 
PostPosted: Tue Feb 21, 2012 1:32 am 
Offline

Joined: Fri Jun 22, 2007 1:09 pm
Posts: 51
Just upgraded. Comskip still crashes on the one .TP file. I changed to verbose=10 but the log file really didn't change much.

http://pastebin.com/RJa0R6sd

Take Care.


Top
 Profile  
 
PostPosted: Tue Feb 21, 2012 7:45 am 
Offline
Site Admin

Joined: Sun Aug 21, 2005 3:49 pm
Posts: 2692
Is your upload speed high enough to upload the recording?
I only need the first 100 MByte, you can abort after that.


Top
 Profile  
 
PostPosted: Tue Feb 21, 2012 6:32 pm 
Offline

Joined: Fri Jun 22, 2007 1:09 pm
Posts: 51
I can upload 100mb without a problem. Where should I upload?


Top
 Profile  
 
PostPosted: Tue Feb 21, 2012 11:22 pm 
Offline
Site Admin

Joined: Sun Aug 21, 2005 3:49 pm
Posts: 2692
The recording has corrupt data at the start causing the decoder to think there is an video size change and the mutithreaded decoder can not handle that
Try to set
thread_count=1
and retest


Top
 Profile  
 
PostPosted: Wed Feb 22, 2012 9:03 pm 
Offline

Joined: Fri Jun 22, 2007 1:09 pm
Posts: 51
I left the threading at 2 hoping the the problem repeats itself. These recording are coming from an HDHomeRun. If I can get it too repeat, hopefully SiliconDust will be able to pinpoint the causse of the corruption.


Top
 Profile  
 
PostPosted: Wed Feb 22, 2012 10:07 pm 
Offline
Site Admin

Joined: Sun Aug 21, 2005 3:49 pm
Posts: 2692
I have several recordings where I can get Comskip to abort when threading is set to 2 or more.
Not need to have this proven.
What you could to is run comskipGUI on the crashing file so you can see in the logginh window the error messages from the decoder stating that frame size changes are not imlemented with the multi threaded decoder


Top
 Profile  
 
PostPosted: Thu Feb 23, 2012 12:33 am 
Offline

Joined: Fri Jun 22, 2007 1:09 pm
Posts: 51
If I run the video with ComskipGUI, comskipGUI typically crashes and I get a not responding error. I was not able to confirm the error you mention.


Top
 Profile  
 
PostPosted: Thu Feb 23, 2012 11:08 am 
Offline
Site Admin

Joined: Sun Aug 21, 2005 3:49 pm
Posts: 2692
Could you run comskip like this

c:\path\to\comskip.exe d:\path\to\file.mpg >stdout.log 2>stderr.log

and send me both stderr.log and stdout.log?


Top
 Profile  
 
PostPosted: Thu Feb 23, 2012 12:54 pm 
Offline

Joined: Fri Jun 22, 2007 1:09 pm
Posts: 51
Here is stderr
http://pastebin.com/uF0UVmZq

stdout is simple
Code:
The commandline used was:
comskip.exe test.tp

Using comskip.ini for initiation values.


Here is the regular log file
http://pastebin.com/iYgWGyvq


Top
 Profile  
 
PostPosted: Thu Feb 23, 2012 1:47 pm 
Offline
Site Admin

Joined: Sun Aug 21, 2005 3:49 pm
Posts: 2692
stderr says
Quote:
Width/height changing with frame threads is not implemented. Update your FFmpeg version to the newest one from Git. If the problem still occurs, it means that your file has a feature which has not been implemented.

So you should set thread_count=1 like mentioned in the faq.


Top
 Profile  
 
PostPosted: Thu Feb 23, 2012 6:13 pm 
Offline

Joined: Fri Jun 22, 2007 1:09 pm
Posts: 51
I have it now set to thread_count=1 and after running some tests, confirmed that that works. I will be working with Silicondust to determine why the file is gettign corrupted. When BeyondTV trys to play the video file, playback stops and I ahev to click on the skip button to move forward 30sec for playback to resume. I am guessing it is the same issue.

Thanks for the support.

Take Care.


Top
 Profile  
 
PostPosted: Thu Feb 23, 2012 7:34 pm 
Offline
Site Admin

Joined: Sun Aug 21, 2005 3:49 pm
Posts: 2692
Well, not sure its corrupted, can the Silicondust create files with switching video resolution?
If not there is a indeed a corruption.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 13 posts ] 

All times are UTC [ DST ]


Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group