DVRMStoMPEG and Comskip - Comskip not exiting

Here you can ask your questions on how to use Comskip for the detection of commercials. Also questions on how to remove commercials are welcome
Post Reply
rlfromm
Posts: 3
Joined: Sat Dec 07, 2013 2:49 pm

DVRMStoMPEG and Comskip - Comskip not exiting

Post by rlfromm » Tue Mar 17, 2015 9:43 pm

Everything was running fine on my Windows 8.1 system. Recently now whenever DVRMStoMPEG calls Comskip to process the commercials, everything works OK and commercial skip files are created. Unfortunately, Comskip never exits and therefore the DVRMStoMPEG process never completes.

Now if I go to Taskmgr and terminate the Comskip task then DVRMStoMPEG process completes and commercial skipping works OK. I have found no error messages.

Does anyone have any idea why Comskip is not exiting?

erik
Site Admin
Posts: 3302
Joined: Sun Aug 21, 2005 3:49 pm

Re: DVRMStoMPEG and Comskip - Comskip not exiting

Post by erik » Wed Mar 18, 2015 8:47 am

What build are you using?

rlfromm
Posts: 3
Joined: Sat Dec 07, 2013 2:49 pm

Re: DVRMStoMPEG and Comskip - Comskip not exiting

Post by rlfromm » Fri Mar 20, 2015 6:01 pm

comskip 0.81.071

rlfromm
Posts: 3
Joined: Sat Dec 07, 2013 2:49 pm

Re: DVRMStoMPEG and Comskip - Comskip not exiting

Post by rlfromm » Fri Mar 20, 2015 7:36 pm

Well now I feel embarrassed. I decided to dig deeper by running Comskip manually using the command line generated from the DVRmsToolbox and guess what happened? The debug window popped open!!! Apparently I forgot to change the "output_debugwindow=" parameter value back to zero after my last tuning tweaks. The problem is resolved.

erik
Site Admin
Posts: 3302
Joined: Sun Aug 21, 2005 3:49 pm

Re: DVRMStoMPEG and Comskip - Comskip not exiting

Post by erik » Sat Mar 21, 2015 10:21 am

Guess I should pin this post :)

Post Reply