Comskip Support Forum

Comskip is a free commercial detector, browse the forum for more information
It is currently Tue Sep 25, 2018 2:20 am

All times are UTC [ DST ]




Post new topic Reply to topic  [ 43 posts ]  Go to page 1, 2, 3  Next
Author Message
PostPosted: Fri Aug 21, 2015 3:57 am 
Offline

Joined: Fri Aug 21, 2015 3:43 am
Posts: 34
I am having trouble with the new gpu decoding feature. I added hardware_decode=1 to my comskip.ini file but no luck. I had gpu-z running as I processed some wtv files using mcebuddy but there was no change on load or core clock. Processing speeds are within 25 fps of each other using different recordings on the same channel, with hardware_decode=0 and hardware_decode=1. My gpu is a gtx 970 running the latest drivers. I am using comskip version 0.81.083. dxva checker says dxva is working on my gpu any assistance is appreciated thanks.


Top
 Profile  
Reply with quote  
PostPosted: Fri Aug 21, 2015 9:01 am 
Offline
Site Admin

Joined: Sun Aug 21, 2005 3:49 pm
Posts: 3210
Can you mail me the comskip log file with
verbose=10
certain h264 profiles can not be decode with hw assist


Top
 Profile  
Reply with quote  
PostPosted: Fri Aug 21, 2015 11:53 am 
Offline
Site Admin

Joined: Sun Aug 21, 2005 3:49 pm
Posts: 3210
Could you test build 0.81.084 and report if it makes a difference?


Top
 Profile  
Reply with quote  
PostPosted: Fri Aug 21, 2015 3:39 pm 
Offline

Joined: Fri Aug 21, 2015 3:43 am
Posts: 34
version 0.81.084 makes no difference although it is about 200 fps faster. I can not find how to attach my log file to this forum, what is your email address. Please note mcebuddy automatically processes all of my recordings so the log is from a re-process thanks

edit:

I just re ran it and I am noticing a slight difference the core clock goes up for the first 1-2 seconds then it does the same 1 or 2 times during the processing. It does not consistently process in the gpu. thanks


Top
 Profile  
Reply with quote  
PostPosted: Fri Aug 21, 2015 4:08 pm 
Offline
Site Admin

Joined: Sun Aug 21, 2005 3:49 pm
Posts: 3210
Could you drag and drop a recording in comskip.exe with in your comskip.ini file the setting
hardware_decode=1

could you first delete the .logo.txt file if it already exists
and run comskip twice
once without the .logo.txt file, once with the .logo.txt present

If the cpu peaks during logo searching that makes sense as this logo searching is very CPU intensive
if the cpu load is low with .logo.txt present the decoding is done in the GPU.

On my test computer my GPU is so underpowered that HW based decoding is substantially slower then CPU so I can not realy test myself

mail to erik at comskip.org


Top
 Profile  
Reply with quote  
PostPosted: Fri Aug 21, 2015 4:22 pm 
Offline

Joined: Fri Aug 21, 2015 3:43 am
Posts: 34
Cpu usage was in the 30's so I am assuming it is not using the gpu. I am sending over the .log file thanks


Top
 Profile  
Reply with quote  
PostPosted: Fri Aug 21, 2015 4:28 pm 
Offline

Joined: Fri Aug 21, 2015 3:43 am
Posts: 34
just sent it thanks


Top
 Profile  
Reply with quote  
PostPosted: Fri Aug 21, 2015 4:35 pm 
Offline
Site Admin

Joined: Sun Aug 21, 2005 3:49 pm
Posts: 3210
Processing speed was 2252.36 fps
The video processing by comskip is alway's CPU based, only the decoding can move to the GPU

With 2250 fps the CPU will remain the limiting factor.

GPU decoding is expected to have its biggest impact when you are running at sub 500 fps because then there is load to shift to the GPU


Top
 Profile  
Reply with quote  
PostPosted: Fri Aug 21, 2015 4:53 pm 
Offline

Joined: Fri Aug 21, 2015 3:43 am
Posts: 34
So basically what you are saying is my processing speeds are too fast for gpu acceleration? thanks


Top
 Profile  
Reply with quote  
PostPosted: Fri Aug 21, 2015 5:45 pm 
Offline
Site Admin

Joined: Sun Aug 21, 2005 3:49 pm
Posts: 3210
Yes, with speeds above 2000 fps the decoding is for sure not the bottleneck anymore and the video analysis can not be split over mutiple cores or moved to GPU so for the moment you hit the performance limit


Top
 Profile  
Reply with quote  
PostPosted: Fri Aug 21, 2015 6:42 pm 
Offline

Joined: Fri Aug 21, 2015 3:43 am
Posts: 34
if the video analysis can not be split over multiple cores then what does the thread_count option do? thanks


Top
 Profile  
Reply with quote  
PostPosted: Fri Aug 21, 2015 9:12 pm 
Offline
Site Admin

Joined: Sun Aug 21, 2005 3:49 pm
Posts: 3210
Thread count is for the video decoder
When you decode mpeg2 in lowres=2 the decoding load is so low it has almost no impact
However when you decode 1080p h264 90% of the work is decoding the video so thread count will have most impact


Top
 Profile  
Reply with quote  
PostPosted: Fri Aug 21, 2015 10:25 pm 
Offline

Joined: Fri Aug 21, 2015 3:43 am
Posts: 34
Thanks for explaining that to me. Also it is good to know that I am getting everything that I can out of comskip performance wise. Thank you.


Top
 Profile  
Reply with quote  
PostPosted: Sat Aug 22, 2015 5:59 pm 
Offline
Site Admin

Joined: Sun Aug 21, 2005 3:49 pm
Posts: 3210
Of course your question if the comskip processing itself (not the decoding) is multi-threaded has started some creative ideas but the will take some time


Top
 Profile  
Reply with quote  
PostPosted: Sat Aug 22, 2015 8:40 pm 
Offline

Joined: Fri Aug 21, 2015 3:43 am
Posts: 34
sounds nice. I look forward to multi core processing some time in the future. thanks

edit:

Please let me know when you have a pre release version ready so I can test it for you. I use comskip on average on 4 different recordings a day and my system is more than powerful enough to handle it. thanks


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 43 posts ]  Go to page 1, 2, 3  Next

All times are UTC [ DST ]


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group