hardware acceleration blues

Here you can ask your questions on how to use Comskip for the detection of commercials. Also questions on how to remove commercials are welcome
erik
Site Admin
Posts: 3344
Joined: Sun Aug 21, 2005 3:49 pm

Re: hardware acceleration blues

Post by erik »

I uploaded 0.81.088 beta to the donators area
Can you test if there is any speed difference when you enable HW acceleration
For mpeg2 its most probably slower

techpro2004
Posts: 36
Joined: Fri Aug 21, 2015 3:43 am

Re: hardware acceleration blues

Post by techpro2004 »

i just downloaded it. I should have a result for you in about 30 min. I removed the thread_count option from my comskip.ini file. thanks

techpro2004
Posts: 36
Joined: Fri Aug 21, 2015 3:43 am

Re: hardware acceleration blues

Post by techpro2004 »

well you are almost there. It works if I drag and drop the wtv file on to comskip.exe but not when called from mcebuddy. please note I am using mcebuddy version 2.4.2 thanks

erik
Site Admin
Posts: 3344
Joined: Sun Aug 21, 2005 3:49 pm

Re: hardware acceleration blues

Post by erik »

Can you set
verbose=10
in comskip.ini and check if the hardware_decode parameter is set to 1

techpro2004
Posts: 36
Joined: Fri Aug 21, 2015 3:43 am

Re: hardware acceleration blues

Post by techpro2004 »

they were already set thanks

erik
Site Admin
Posts: 3344
Joined: Sun Aug 21, 2005 3:49 pm

Re: hardware acceleration blues

Post by erik »

Strange, so no difference when run from mcebuddy
Can you check the comskip version number in the log file to see if you run the right build?

techpro2004
Posts: 36
Joined: Fri Aug 21, 2015 3:43 am

Re: hardware acceleration blues

Post by techpro2004 »

according to the mcebuddy log version 0.81.088 was used with these arguments: --ini="C:\comskip\comskip.ini" --output="E:\mcebuddy temp\working0" "E:\mcebuddy temp\working0\Good Day New York-2015-09-07 0909.wtv". the comskip.exe file is also in c:\comskip. thanks

erik
Site Admin
Posts: 3344
Joined: Sun Aug 21, 2005 3:49 pm

Re: hardware acceleration blues

Post by erik »

Can you do a manual run and a run from mcebuddy and compare the two log files?

techpro2004
Posts: 36
Joined: Fri Aug 21, 2015 3:43 am

Re: hardware acceleration blues

Post by techpro2004 »

the manual log is much larger. I just sent you an email with both of them.

erik
Site Admin
Posts: 3344
Joined: Sun Aug 21, 2005 3:49 pm

Re: hardware acceleration blues

Post by erik »

There is a huge unexpected difference between the decoded video of the manual run and the mcebuddy run.The file processing from within mcebuddy has a very different black level. Is there any postprocessing done by mcebuddy?
Can you disable the hardware decoding and see if there is any difference between running from mcebuddy and running manually?

techpro2004
Posts: 36
Joined: Fri Aug 21, 2015 3:43 am

Re: hardware acceleration blues

Post by techpro2004 »

I copied the file before mcebuddy ran so no post processing was done. I will try it with changing both lowres=0 and disabling hardware acceleration. on different runs thanks

erik
Site Admin
Posts: 3344
Joined: Sun Aug 21, 2005 3:49 pm

Re: hardware acceleration blues

Post by erik »

i will ask the developper of mcebuddy for an explanation

techpro2004
Posts: 36
Joined: Fri Aug 21, 2015 3:43 am

Re: hardware acceleration blues

Post by techpro2004 »

I just sent you a email with the logs

Post Reply