ComSkip Hang Issue

Here you can ask your questions on how to use Comskip for the detection of commercials. Also questions on how to remove commercials are welcome
Post Reply
Donator111
Posts: 6
Joined: Sun Feb 25, 2018 1:35 am

ComSkip Hang Issue

Post by Donator111 » Sun Feb 25, 2018 1:41 am

I'm having more and more hang issues recently...on numerous channels. The hang results with the below log....any ideas on the cause? The last lines continue until I manually cancel it.

[mpeg2video @ 051dbf00] 00 motion_type at 0 287
[mpeg2video @ 051dbf00] 00 motion_type at 129 288
[mpeg2video @ 051dbf00] 00 motion_type at 1 292
[mpeg2video @ 051dbf00] mb incr damaged
[mpeg2video @ 051dbf00] 00 motion_type at 0 296
[mpeg2video @ 051dbf00] 00 motion_type at 4 298
[mpeg2video @ 051dbf00] 00 motion_type at 67 299
[mpeg2video @ 051dbf00] 00 motion_type at 64 300
[mpeg2video @ 051dbf00] skip with previntra
[mpeg2video @ 051dbf00] 00 motion_type at 19 303
[mpeg2video @ 051dbf00] 00 motion_type at 2 305
[mpeg2video @ 051dbf00] 00 motion_type at 8 307
[mpeg2video @ 051dbf00] 00 motion_type at 4 308
[mpeg2video @ 051dbf00] mb incr damaged
[mpeg2video @ 051dbf00] 00 motion_type at 5 311
[mpeg2video @ 051dbf00] 00 motion_type at 118 312
[mpeg2video @ 051dbf00] ac-tex damaged at 0 316
[mpeg2video @ 051dbf00] ac-tex damaged at 0 317
[mpeg2video @ 051dbf00] ac-tex damaged at 0 318
[mpeg2video @ 051dbf00] ac-tex damaged at 0 319
[mpeg2video @ 051dbf00] ac-tex damaged at 0 320
[mpeg2video @ 051dbf00] ac-tex damaged at 0 321
[mpeg2video @ 051dbf00] ac-tex damaged at 0 322
[mpeg2video @ 051dbf00] ac-tex damaged at 0 323
[mpeg2video @ 051dbf00] qscale == 0
[mpeg2video @ 051dbf00] qscale == 0
[mpeg2video @ 051dbf00] qscale == 0
[mpeg2video @ 051dbf00] qscale == 0
[mpeg2video @ 051dbf00] qscale == 0
[mpeg2video @ 051dbf00] qscale == 0
[mpeg2video @ 051dbf00] qscale == 0
[mpeg2video @ 051dbf00] qscale == 0

erik
Site Admin
Posts: 3310
Joined: Sun Aug 21, 2005 3:49 pm

Re: ComSkip Hang Issue

Post by erik » Sun Feb 25, 2018 8:03 am

Can you check the quality of your TV signal?
Seems there are many bit stream errors

Donator111
Posts: 6
Joined: Sun Feb 25, 2018 1:35 am

Re: ComSkip Hang Issue

Post by Donator111 » Sun Feb 25, 2018 8:41 pm

The quality is great...in fact, I'm able to convert these shows without comskip applied and they're perfect. Any ideas? I use MCEBuddy...not sure if that matters or not.

erik
Site Admin
Posts: 3310
Joined: Sun Aug 21, 2005 3:49 pm

Re: ComSkip Hang Issue

Post by erik » Sun Feb 25, 2018 8:59 pm

The errors detected are in the bit stream
There is not much i can do about them
However these do not have to be the cause of the crash.
Can you run comskip on a file from a cmd window? This will show the latest error message even when not written to a log file

Donator111
Posts: 6
Joined: Sun Feb 25, 2018 1:35 am

Re: ComSkip Hang Issue

Post by Donator111 » Mon Feb 26, 2018 2:51 am

Thanks, no worries on the detected errors. My post included lines from the cmd window (I dragged the file to the shortcut on the desktop). The last line repeats until I kill it. Would a different verbose level or another method help identify the crash reason? This seems to be the culprit: [mpeg2video @ 051dbf00] qscale == 0

Thanks!

erik
Site Admin
Posts: 3310
Joined: Sun Aug 21, 2005 3:49 pm

Re: ComSkip Hang Issue

Post by erik » Mon Feb 26, 2018 8:13 am

This implies comskip is hanging in the mpeg decoder.
Can you send me the shortest (less then 100 MByte) recording that causes comskip to hang?

Donator111
Posts: 6
Joined: Sun Feb 25, 2018 1:35 am

Re: ComSkip Hang Issue

Post by Donator111 » Tue Feb 27, 2018 1:21 am

Sure thing...any hints on narrowing the 5GB file down to a 100mb file where the error occurs?

erik
Site Admin
Posts: 3310
Joined: Sun Aug 21, 2005 3:49 pm

Re: ComSkip Hang Issue

Post by erik » Tue Feb 27, 2018 8:45 am

Make some small recordings and see if they fail???

Donator111
Posts: 6
Joined: Sun Feb 25, 2018 1:35 am

Re: ComSkip Hang Issue

Post by Donator111 » Sat Mar 03, 2018 12:52 am

I did did some resets and refreshes of my cable hardware. I'm going to see if the same shows cause the same issues this weekend. If so, I'll pull the clips together. I'll know tomorrow!
Thanks!

Donator111
Posts: 6
Joined: Sun Feb 25, 2018 1:35 am

Re: ComSkip Hang Issue

Post by Donator111 » Sun Mar 11, 2018 1:53 am

So far, so good!

Post Reply