EDL Output UTF-8 BOM Encoding?

Here you can ask your questions on how to use Comskip for the detection of commercials. Also questions on how to remove commercials are welcome
Post Reply
giant25
Posts: 1
Joined: Mon Mar 11, 2019 5:51 pm

EDL Output UTF-8 BOM Encoding?

Post by giant25 » Mon Mar 11, 2019 5:58 pm

I've been using Comskip 81.092 for a while now with no issues and have been watching shows through Kodi. I recently updated to 82.003 and I noticed that the first line of the EDL file is no longer working properly. Basically, when playing a recording, I immediately see a commercial skip that jumps all the way to the second time on the first line, regardless of the first time on the first line. I opened the new EDL files (created with 82.003) and noticed that they are UTF-8 BOM encoded, while all EDLs from the 81.092 Comskip are UTF-8 encoded. When I switch my new files to just UTF-8 using Notepad++, commercial skips now work as they should (I can reproduce this by toggling any file between these two encoding schemes). Any idea what may have changed between those two versions or if there's any way to force it to be a certain encoding? Thanks so much.

**UPDATE: Looks like MCEBuddy is what is adding the BOM to the EDL file, so it may not be a Comskip change. MCEBuddy is looking to disable adding BOM to the EDL in their next beta.**

Post Reply