Comskip and mencoder

Here you can ask your questions on how to use Comskip for the detection of commercials. Also questions on how to remove commercials are welcome
Post Reply
wntrmte
Posts: 15
Joined: Thu Mar 23, 2006 4:30 am

Comskip and mencoder

Post by wntrmte » Thu Mar 23, 2006 4:35 am

Hello,

I am using comskip79_28 and mencoder for commercial detection
and cutting.
I have a Fusion HDTV5 USB Gold
The comskip part appears to run ok, but the mencoder portion gives me the following errors. The original file plays fine. What do I do?

G:\My Videos>"G:\My Videos\mencoder.exe" "G:\My Videos\Star Trek- Enterprise.mp
" -edl "G:\My Videos\Star Trek- Enterprise.edl" -oac copy -ovc copy -of mpeg -o
".mpg"
MEncoder 1.0pre7-3.4.2 (C) 2000-2005 MPlayer Team
CPU: Advanced Micro Devices Athlon MP/XP Thoroughbred (Family: 6, Stepping: 1)
Detected cache-line size is 64 bytes
CPUflags: Type: 6 MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 0 SSE2: 0
Compiled with runtime CPU detection - WARNING - this is not optimal!
To get best performance, recompile MPlayer with --disable-runtime-cpudetection.
File not found: 'frameno.avi'
Failed to open frameno.avi
success: format: 0 data: 0x0 - 0x6d853211
MPEG-PS file format detected.
VIDEO: MPEG2 704x480 (aspect 2) 29.970 fps 4350.0 kbps (543.8 kbyte/s)
[V] filefmt:2 fourcc:0x10000002 size:704x480 fps:29.97 ftime:=0.0334
==========================================================================
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3

Too many video packets in the buffer: (1284 in 8393121 bytes).
Maybe you are playing a non-interleaved stream/file or the codec failed?
For AVI files, try to force non-interleaved mode with the -ni option.
ADecoder init failed :(
ADecoder init failed :(
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders

Too many video packets in the buffer: (1284 in 8393121 bytes).
Maybe you are playing a non-interleaved stream/file or the codec failed?
For AVI files, try to force non-interleaved mode with the -ni option.
Unknown/missing audio format -> no sound
ADecoder init failed :(
Requested audio codec family [mad] (afm=libmad) not available.
Enable it at compilation.
Cannot find codec for audio format 0x50.
Read DOCS/HTML/en/codecs.html!
==========================================================================
PACKET SIZE: 2048 bytes
videocodec: framecopy (704x480 24bpp fourcc=10000002)
Writing AVI header...
Limiting audio preload to 0.4s
Increasing audio density to 4
INITIAL DELAY of 2 frames 0fps Trem: 0min 0mb A-V:0.000 [0:0]
Pos: 148.4s 4449f ( 4%) 645fps Trem: 2min 1675mb A-V:0.000 [3871:0]
Too many audio packets in the buffer: (4096 in 3129344 bytes).
Maybe you are playing a non-interleaved stream/file or the codec failed?
For AVI files, try to force non-interleaved mode with the -ni option.

Too many audio packets in the buffer: (4096 in 3129344 bytes).
Maybe you are playing a non-interleaved stream/file or the codec failed?
For AVI files, try to force non-interleaved mode with the -ni option.

Too many audio packets in the buffer: (4096 in 3129344 bytes).
Maybe you are playing a non-interleaved stream/file or the codec failed?
For AVI files, try to force non-interleaved mode with the -ni option.

Too many audio packets in the buffer: (4096 in 3129344 bytes).
Maybe you are playing a non-interleaved stream/file or the codec failed?
For AVI files, try to force non-interleaved mode with the -ni option.

Too many audio packets in the buffer: (4096 in 3129344 bytes).
Maybe you are playing a non-interleaved stream/file or the codec failed?
For AVI files, try to force non-interleaved mode with the -ni option.

Too many audio packets in the buffer: (4096 in 3129344 bytes).
Maybe you are playing a non-interleaved stream/file or the codec failed?
For AVI files, try to force non-interleaved mode with the -ni option.

Writing AVI index...

Overhead: 1.146% (823279 / 71845905)
Fixing AVI header...

Video stream: 3871.831 kbit/s (483978 bps) size: 71845905 bytes 148.448 secs
4449 frames

G:\My Videos>

erik
Site Admin
Posts: 3320
Joined: Sun Aug 21, 2005 3:49 pm

Post by erik » Thu Mar 23, 2006 1:08 pm

I am not sure if mencoder can deal with AC3 audio?
Does the input file contain AC3?
Did you check if Mencoder can deal with AC3?
Could you upload a fragment of the stream to my server, if yes, I will PM you the upload details.

wntrmte
Posts: 15
Joined: Thu Mar 23, 2006 4:30 am

Post by wntrmte » Thu Mar 23, 2006 10:27 pm

How do I check for AC3 content? I think the answer is yes, but I would probably need to check to make sure. How do I do this?
I can upload a fragment, but how to I only obtain/copy a fragment?

Regards,
Greg

stattik
Posts: 17
Joined: Sat Dec 24, 2005 9:09 pm

Post by stattik » Fri Mar 24, 2006 4:39 pm

Looks like you're using Mpeg2 for audio, not AC3. I'd try a new version of mencoder. Try here:

http://ffdshow.faireal.net/mirror/mplayer/

Post Reply