Request - logo percentage display

To discuss the tuning of comskip and for posting your ini files
Post Reply
sheppy99
Posts: 88
Joined: Mon May 10, 2010 2:44 am

Request - logo percentage display

Post by sheppy99 »

Is there any chance of having the logo percentage display in the debug window when stepping through the results on a frame by frame basis? I know there already is a bar graph but if I click on each individual frame the logo either says what the threshold is set to or 0. This change would make logo tuning much easier.
Thanks
erik
Site Admin
Posts: 3365
Joined: Sun Aug 21, 2005 3:49 pm

Re: Request - logo percentage display

Post by erik »

YOu don't mean the yellow line?
sheppy99
Posts: 88
Joined: Mon May 10, 2010 2:44 am

Re: Request - logo percentage display

Post by sheppy99 »

I do, is there any way of seeing what the value is on a frame by frame basis? I've had a couple of instances where the logo has returned prematurely and I've needed to do a lot of playing with the parameters to get reliable detection. If there was any way of finding a problem frame, rescanning and seeing what difference any tweaks that had been made had done.
erik
Site Admin
Posts: 3365
Joined: Sun Aug 21, 2005 3:49 pm

Re: Request - logo percentage display

Post by erik »

Sorry, the exact logo percentage of the actual frame can only be seen in the .csv file.
It is only updated evey 25 (?) frames
sheppy99
Posts: 88
Joined: Mon May 10, 2010 2:44 am

Re: Request - logo percentage display

Post by sheppy99 »

in the csv works for me, but all I can find is either 1 or 0 in the logo column - what are the unlabeled columns for?
are the frames in the csv likely to match the frames when viewed in videoredo?
I use skip_b_frames=2 in case this makes any difference.

The columns I have are labelled:
frame brightness scene_change logo uniform sound minY MaxY ar_ratio goodEdge isblack cutscene 2500

Leaving 3 at the end
erik
Site Admin
Posts: 3365
Joined: Sun Aug 21, 2005 3:49 pm

Re: Request - logo percentage display

Post by erik »

goodEdge is the amount of good edges found inside the logo mask.
It is scaled between 0 and 500 where 500 means 100% of the edges inside the logo mask are triggered.
sheppy99
Posts: 88
Joined: Mon May 10, 2010 2:44 am

Re: Request - logo percentage display

Post by sheppy99 »

superb, I'll work with that. I've learnt a lot about how it works in the last few days and even difficult logos seem to be working with much experimentation.
Do you have any suggestions as to what is likely to work on a channel with no logo or is it easier to just skip manually?
erik
Site Admin
Posts: 3365
Joined: Sun Aug 21, 2005 3:49 pm

Re: Request - logo percentage display

Post by erik »

Did you already have a look at the punish/reward modifiers?
You can use them to score on bright/dark, load/quiet, etc segments
Then there is the cutframe function to create cutpoints based on static pictures or scenes used before/after shows
sheppy99
Posts: 88
Joined: Mon May 10, 2010 2:44 am

Re: Request - logo percentage display

Post by sheppy99 »

superb - is there any documentation on this - apologies if I've missed it! :oops:
There seems to be about 25 black frames between ad breaks which might help.
erik
Site Admin
Posts: 3365
Joined: Sun Aug 21, 2005 3:49 pm

Re: Request - logo percentage display

Post by erik »

mmm, documentation.
Not my strongest point.
In this case I am afraid that you have to look at comskip.txt inside the distribution zip file and search the forum for examples on how to use.
Do keep in mind that in comskip.txt the comment is AFTER the parameter
sheppy99
Posts: 88
Joined: Mon May 10, 2010 2:44 am

Re: Request - logo percentage display

Post by sheppy99 »

OK I'll give it a go and post any useful tips I find on here.
Cheers
Post Reply