Panic Volume buffer

Where all the bugs are reported and discussed
Post Reply
mogulman
Posts: 52
Joined: Tue Dec 06, 2011 6:58 pm

Panic Volume buffer

Post by mogulman » Sun May 24, 2015 9:27 pm

Any way to fix this?

I kind of gave up about a year ago. It only seems to happen on LiveTV. If I set up DVRMStoolbox file watcher to wait 20 mins before scanning, then it doesn't happen so much. Maybe like once/month or so. I'm on .61, because on later versions if I get a Panic volume buffer error, then the show isn't scanned at all. At least with .61, it will process as much as possible. I guess there is the possibility of a loop, but I haven't run into that.

Last version I tried was .64. Then I went back to .61.

I think you know which error, but looks like this in the logs:
07075: Panic volume buffer
07076: Audio PTS jumped -23 frames at frame 0
07077: Audio PTS jumped -22 frames at frame 0
07078: Audio PTS jumped -23 frames at frame 0
07079: Audio PTS jumped -22 frames at frame 0
07080: Audio PTS jumped -24 frames at frame 0
07081: Audio PTS jumped -23 frames at frame 0
07082: Audio PTS jumped -24 frames at frame 0
07083: Audio PTS jumped -23 frames at frame 0
07084: Audio PTS jumped -23 frames at frame 0
07085: Audio PTS jumped -22 frames at frame 0
07086: Audio PTS jumped -23 frames at frame 0
07087: Audio PTS jumped -24 frames at frame 0
07088: Audio PTS jumped -23 frames at frame 0
07089: Audio PTS jumped -22 frames at frame 0
07090: Audio PTS jumped -24 frames at frame 0

erik
Site Admin
Posts: 3310
Joined: Sun Aug 21, 2005 3:49 pm

Re: Panic Volume buffer

Post by erik » Mon May 25, 2015 8:04 am

Can you test with the latest build?
Then you give me access to a recording?

mogulman
Posts: 52
Joined: Tue Dec 06, 2011 6:58 pm

Re: Panic Volume buffer

Post by mogulman » Fri May 29, 2015 2:09 am

erik wrote:Can you test with the latest build?
Then you give me access to a recording?
I can, the problem is it only happens with LiveTV recording.

I think we went back and forth on it a year ago. I'll try with the newest version though. Should I bring the wait time down from 20 mins to 10? I think when I did that last time, I saw the error more often.

I remember when I tried .64, that it would stop when it hit the Panic Volume Buffer.

erik
Site Admin
Posts: 3310
Joined: Sun Aug 21, 2005 3:49 pm

Re: Panic Volume buffer

Post by erik » Fri May 29, 2015 9:43 am

Substantial changes have been implemented since .064
Good to test with latest build

mogulman
Posts: 52
Joined: Tue Dec 06, 2011 6:58 pm

Re: Panic Volume buffer

Post by mogulman » Thu Jun 11, 2015 3:12 am

Tried .77. No Panic volume but it stopped about halfway through. Comskip was started 10 mins after the recording started.

Here is a portion of the log.

Do you want me to upload stuff somewhere?

Retry=0 at frame=107515, time= 1794.04 seconds
[mpeg2video @ 62d93880] Invalid frame dimensions 0x0.
[mpeg2video @ 62d93880] Invalid frame dimensions 0x0.
[mpeg2video @ 62d93880] Invalid frame dimensions 0x0.
[mpeg2video @ 62d93880] Invalid frame dimensions 0x0.
[mpeg2video @ 62d93880] Invalid frame dimensions 0x0.
[mpeg2video @ 62d93880] Invalid frame dimensions 0x0.
[mpeg2video @ 62d93880] Invalid frame dimensions 0x0.
[mpeg2video @ 62d93880] Invalid frame dimensions 0x0.
[mpeg2video @ 62d93880] Invalid frame dimensions 0x0.
[mpeg2video @ 62d93880] Invalid frame dimensions 0x0.
[mpeg2video @ 62d93880] Invalid frame dimensions 0x0.
[mpeg2video @ 62d93880] Invalid frame dimensions 0x0.
[mpeg2video @ 62d93880] Invalid frame dimensions 0x0.
[mpeg2video @ 62d93880] Invalid frame dimensions 0x0.
[mpeg2video @ 62d93880] Invalid frame dimensions 0x0.
[mpeg2video @ 62d93880] Invalid frame dimensions 0x0.
[mpeg2video @ 62d93880] Invalid frame dimensions 0x0.
[mpeg2video @ 62d93880] Invalid frame dimensions 0x0.
[mpeg2video @ 62d93880] Invalid frame dimensions 0x0.
[mpeg2video @ 62d93880] get_buffer() failed
[mpeg2video @ 62d93880] thread_get_buffer() failed
[mpeg2video @ 62d93880] get_buffer() failed (-12 00000000)
Could not open video codec

erik
Site Admin
Posts: 3310
Joined: Sun Aug 21, 2005 3:49 pm

Re: Panic Volume buffer

Post by erik » Thu Jun 11, 2015 6:46 am

Since the introduction of HW decoding there are some problems.
Try 0.81.076

mogulman
Posts: 52
Joined: Tue Dec 06, 2011 6:58 pm

Re: Panic Volume buffer

Post by mogulman » Fri Jun 12, 2015 10:38 pm

Tried .76. Still not working as well as .61. Sent an email with logs.

mogulman
Posts: 52
Joined: Tue Dec 06, 2011 6:58 pm

Re: Panic Volume buffer

Post by mogulman » Sun Aug 09, 2015 8:53 pm

Almost TV season coming up for the US. Anything new happening after .76 that I should try? or stick with .61?

erik
Site Admin
Posts: 3310
Joined: Sun Aug 21, 2005 3:49 pm

Re: Panic Volume buffer

Post by erik » Mon Aug 10, 2015 10:23 pm

Working on a very big improvement
Almost ready

Post Reply