Debian 8.9 Problem with Make for ComSkip

Here you can ask your questions on how to use Comskip for the detection of commercials. Also questions on how to remove commercials are welcome
Post Reply
droogish
Posts: 2
Joined: Thu Nov 16, 2017 1:08 pm

Debian 8.9 Problem with Make for ComSkip

Post by droogish » Thu Nov 16, 2017 1:51 pm

Hi,

I am new to Comskip and am trying to compile on Debian 8.9. I have put in all the dependencies and build ffmpeg. Also put the dependencies and completed the configure on the Comskip.

When I run the make I get the error

mpeg2dec.c:1202:57: error: ‘CODEC_FLAG_GRAY’ undeclared (first use in this function)
if (!hardware_decode) is->video_st->codec->flags |= CODEC_FLAG_GRAY;

I know I am missing something but cant' quite figure out where or what declares this.

For the configure of Comskip I am using the command below otherwise i am just following the instructions to compile from the git hub.

PATH="$HOME/bin:$PATH" PKG_CONFIG_PATH="$HOME/ffmpeg_build/lib/pkgconfig" ./configure --bindir="$HOME/bin"

many thanks for any help

droogish
Posts: 2
Joined: Thu Nov 16, 2017 1:08 pm

Re: Debian 8.9 Problem with Make for ComSkip

Post by droogish » Thu Nov 16, 2017 4:07 pm

Sorry I found my own issue and resolution. I think the define CODEC_FLAG_GRAY comes from the ffmpeg, I am compiling from the git hub version which has defined AV_CODEC_FLAG_GREY

I added the lines below to mpeg2dec.c and it is compiling correctly. I am assuming that there was a change in the later versions of ffmpeg.

#ifndef CODEC_FLAG_GRAY
#define CODEC_FLAG_GRAY AV_CODEC_FLAG_GRAY
#endif

McGuyver
Posts: 10
Joined: Fri Oct 25, 2013 6:39 am

Re: Debian 8.9 Problem with Make for ComSkip

Post by McGuyver » Fri Nov 17, 2017 4:20 pm

They actually made that change about 2 years ago.

https://github.com/FFmpeg/FFmpeg/commit ... 8a637d1e5f

Post Reply