comskip82_007_donators

Where all the bugs are reported and discussed
Paint
Posts: 7
Joined: Wed Nov 08, 2017 3:42 pm

comskip82_007_donators

Post by Paint »

When running comskip82_007_donators (comskip.exe) on my Windows 7 x64 machine, I get the following error:

Code: Select all

The procedure entry point ReleaseSemaphore could not be located in the dynamic link library api-ms-win-core-synch-I1-2-0.dll
The version is unusable and I had to roll back to the previous comskip82_003_donators build.

erik
Site Admin
Posts: 3338
Joined: Sun Aug 21, 2005 3:49 pm

Re: comskip82_007_donators

Post by erik »

Thanks for checking, I will remove and update a.s.a.p.

waylo
Posts: 13
Joined: Sat Mar 14, 2009 9:43 pm

Re: comskip82_007_donators

Post by waylo »

I have the exactly same thing on my 2 Windows 7 x64 machines.

I googled some 'fixes' but they seem very sketchy (copying and adding specific .dll files to the Windows folders) so I did not proceed further.

erik
Site Admin
Posts: 3338
Joined: Sun Aug 21, 2005 3:49 pm

Re: comskip82_007_donators

Post by erik »

Don't do anything on your computer!!!!!!
I had some build problems that I assumed where fixed but it appears not
Be patient

erik
Site Admin
Posts: 3338
Joined: Sun Aug 21, 2005 3:49 pm

Re: comskip82_007_donators

Post by erik »

I update build 0.82.007
Can someone test?

Paint
Posts: 7
Joined: Wed Nov 08, 2017 3:42 pm

Re: comskip82_007_donators

Post by Paint »

erik wrote:I update build 0.82.007
Can someone test?
Just downloaded the newest version. I get the same error.

erik
Site Admin
Posts: 3338
Joined: Sun Aug 21, 2005 3:49 pm

Re: comskip82_007_donators

Post by erik »

Terrrible.

Paint
Posts: 7
Joined: Wed Nov 08, 2017 3:42 pm

Re: comskip82_007_donators

Post by Paint »

erik wrote:Terrrible.
Happy to help debug further... Let me how I can help

erik
Site Admin
Posts: 3338
Joined: Sun Aug 21, 2005 3:49 pm

Re: comskip82_007_donators

Post by erik »

My build environment collapsed with the ffmpeg update
This will take some more time to repair

waylo
Posts: 13
Joined: Sat Mar 14, 2009 9:43 pm

Re: comskip82_007_donators

Post by waylo »

Paint wrote:
erik wrote:Terrrible.
Happy to help debug further... Let me how I can help
Ditto here.

erik
Site Admin
Posts: 3338
Joined: Sun Aug 21, 2005 3:49 pm

Re: comskip82_007_donators

Post by erik »

New build 0.82.007 released
Can you guy's test?

waylo
Posts: 13
Joined: Sat Mar 14, 2009 9:43 pm

Re: comskip82_007_donators

Post by waylo »

Sorry erik, running the executable gives the same error (Entry Point Not Found):

The procedure entry point ReleaseSemaphore could not be located in the dynamic link library api-ms-win-core-sync-I1-2-0.dll.

erik
Site Admin
Posts: 3338
Joined: Sun Aug 21, 2005 3:49 pm

Re: comskip82_007_donators

Post by erik »

Did some googling. This seems to be an error that randomly appears with the lastest mingw toolchain I use and running comskip on (older?) windows 7 machines.
For now there is not much I can do as I needed the newer toolchain for the latest decoders.
One someone with a windows 8 or 10 machine starts to complain I know its something else and I will start digging again

waylo
Posts: 13
Joined: Sat Mar 14, 2009 9:43 pm

Re: comskip82_007_donators

Post by waylo »

Thanks for the update. I'll run it on my Win10 HTPC and see what happens.

Paint
Posts: 7
Joined: Wed Nov 08, 2017 3:42 pm

Re: comskip82_007_donators

Post by Paint »

erik wrote:Did some googling. This seems to be an error that randomly appears with the lastest mingw toolchain I use and running comskip on (older?) windows 7 machines.
For now there is not much I can do as I needed the newer toolchain for the latest decoders.
One someone with a windows 8 or 10 machine starts to complain I know its something else and I will start digging again

seems like it is working on my Win10 machine, but not on Windows 7.

Any other workarounds? I know that many of us are probably using Windows 7 still because its the last version that Windows Media Center is officially supported.

Post Reply